R1
interface FastEthernet0/0
ip address 10.0.0.254 255.255.255.0
standby 1 ip 10.0.0.1
end
R2
interface FastEthernet0/0
ip address 10.0.0.253 255.255.255.0
standby 1 ip 10.0.0.1
R3
interface FastEthernet0/0
ip address 10.0.0.252 255.255.255.0
standby 1 ip 10.0.0.1
end
********************************LOGS********************
R1
R1#sh standby
FastEthernet0/0 - Group 1
State is Active
2 state changes, last state change 00:16:20
Virtual IP address is 10.0.0.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.904 secs
Preemption disabled
Active router is local
Standby router is 10.0.0.253, priority 100 (expires in 7.884 sec)
Priority 100 (default 100)
Group name is "hsrp-Fa0/0-1" (default)
R1#
R2
FastEthernet0/0 - Group 1
State is Standby
4 state changes, last state change 00:15:00
Virtual IP address is 10.0.0.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.492 secs
Preemption disabled
Active router is 10.0.0.254, priority 100 (expires in 8.540 sec)
Standby router is local
Priority 100 (default 100)
Group name is "hsrp-Fa0/0-1" (default)
R2#
R3
R3#sh standby
FastEthernet0/0 - Group 1
State is Listen
3 state changes, last state change 00:17:10
Virtual IP address is 10.0.0.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Preemption disabled
Active router is 10.0.0.254, priority 100 (expires in 8.824 sec)
Standby router is 10.0.0.253, priority 100 (expires in 9.792 sec)
Priority 100 (default 100)
Group name is "hsrp-Fa0/0-1" (default)
Case 1 - interface is down
R2(config)#int fa0/0
R2(config-if)#shut
R2#sh standby
FastEthernet0/0 - Group 1
State is Init (interface down)
R3
R3#sh standby
FastEthernet0/0 - Group 1
State is Standby >>>> This is now in standby mode
Case 2 Active router is down
R1
int f0/0
shut
R3#
*Mar 1 00:37:26.051: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active
R3#
R3#sh standby
FastEthernet0/0 - Group 1
State is Active
5 state changes, last state change 00:03:03
Virtual IP address is 10.0.0.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
10.0.0.1 icmp_seq=259 ttl=255 time=46.800 ms
10.0.0.1 icmp_seq=260 ttl=255 time=46.800 ms
10.0.0.1 icmp_seq=261 timeout With a packet drop traffic switched over
10.0.0.1 icmp_seq=262 ttl=255 time=62.400 ms
10.0.0.1 icmp_seq=263 ttl=255 time=62.400 ms
*****************
Sh arp
***************
VPCS[1]> arp
00:00:0c:07:ac:01 10.0.0.1 expires in 111 seconds
R3#sh ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.1 - 0000.0c07.ac01 ARPA FastEthernet0/0
Internet 10.0.0.10 4 0050.7966.6800 ARPA FastEthernet0/0
Internet 10.0.0.252 - c202.1850.0000 ARPA FastEthernet0/0
If a router , which was active earlier , is up again, there will be no change in active gateway this router will be in standby mode.
R1(config)#int fa0/0
R1(config-if)#no shut
R1(config-if)#^Z
R#
R1#
*Mar 1 00:44:20.503: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby
R1#
to make this router again an active gateway preempt is used.
R1(config)#int fa0/0
R1(config-if)#standby 1 preempt delay minimum 3
R1(config-if)#standby 1 priority 200
R1#
*Mar 1 00:50:02.187: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar 1 00:50:05.251: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active
R1#sh
in 3 second this router is again ACTIVE.