Case 1 - Understanding of forwarding address
Case 2. Suppressing forwarding address to make route reachable.
Case 1 - Understanding of forwarding address
R6
interface Loopback1
ip address 66.6.6.6 255.255.255.255
!
interface Loopback10
ip address 66.6.7.7 255.255.255.255
router ospf 10
area 3 nssa
redistribute connected subnets route-map fasup
route-map fasup permit 10
match interface Loopback1 Loopback10
With OSPF database lookups on external routes, the Forward Address
field determines who the next recursive lookup should be performed toward.
field determines who the next recursive lookup should be performed toward.
With typical Type-5 External LSAs,the forward address is normally set to 0.0.0.0. This means that the next lookup should be performed toward the Advertising Router.
As in N2 route FA is router,s address.
As in N2 route FA is router,s address.
in R6
Type-7 AS External Link States (Area 3)
Link ID ADV Router Age Seq# Checksum Tag
66.6.6.6 69.4.1.1 876 0x80000001 0x00B3FA 0
66.6.7.7 69.4.1.1 876 0x80000001 0x009E0E 0
R6#
R5#sh ip route | in 66
66.0.0.0/32 is subnetted, 2 subnets
O N2 66.6.6.6 [110/20] via 56.0.0.6, 00:06:14, FastEthernet0/1
O N2 66.6.7.7 [110/20] via 56.0.0.6, 00:06:14, FastEthernet0/1
R5
R5#sh ip ospf database external 66.6.6.6
OSPF Router with ID (55.5.5.5) (Process ID 10)
Type-5 AS External Link States
LS age: 486
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 66.6.6.6 (External Network Number )
Advertising Router: 55.5.5.5
LS Seq Number: 80000001
Checksum: 0x8A33
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 69.1.1.1
External Route Tag: 0
*************************
R5#sh ip ospf database nssa-external 66.6.6.6
*************************
OSPF Router with ID (55.5.5.5) (Process ID 10)
Type-7 AS External Link States (Area 3)
Routing Bit Set on this LSA in topology Base with MTID 0
LS age: 1114
Options: (No TOS-capability, Type 7/5 translation, DC, Upward)
LS Type: AS External Link
Link State ID: 66.6.6.6 (External Network Number )
Advertising Router: 69.4.1.1
LS Seq Number: 80000001
Checksum: 0xB3FA
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 69.1.1.1
External Route Tag: 0
*************************8
33.0.0.0/32 is subnetted, 1 subnets
O E2 33.33.33.33 [110/20] via 25.0.0.2, 00:01:03, FastEthernet0/0
[110/20] via 15.0.0.1, 00:01:03, FastEthernet2/0
33.0.0.0/32 is subnetted, 1 subnets
O E2 33.33.33.33 [110/20] via 25.0.0.2, 00:01:03, FastEthernet0/0
[110/20] via 15.0.0.1, 00:01:03, FastEthernet2/0
R5#sh ip ospf database external 33.33.33.33
OSPF Router with ID (55.5.5.5) (Process ID 10)
Type-5 AS External Link States
Routing Bit Set on this LSA in topology Base with MTID 0
LS age: 136
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 33.33.33.33 (External Network Number )
Advertising Router: 39.1.4.1
LS Seq Number: 80000001
Checksum: 0x6985
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 0.0.0.0
External Route Tag: 0
R2
R2#sh ip ospf database external 66.6.6.6
OSPF Router with ID (2.2.2.2) (Process ID 10)
Type-5 AS External Link States
LS age: 27
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 66.6.6.6 (External Network Number )
Advertising Router: 55.5.5.5
LS Seq Number: 80000004
Checksum: 0x8436
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 69.1.1.1
External Route Tag: 0
Case 2. Suppressing forwarding address to make route reachable.
In R2 66.6.6.6/32 is not reachable because forwarding address 69.1.1.1 is not in routing table.
But 66.6.6.6 is in OSPF database
R2#sh ip route 69.1.1.1
% Subnet not in table
R2#sh ip route 66.6.6.6
% Network not in table
R2#
R2#sh ip ospf database external 66.6.6.6
OSPF Router with ID (2.2.2.2) (Process ID 10)
Type-5 AS External Link States
LS age: 27
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 66.6.6.6 (External Network Number )
Advertising Router: 55.5.5.5
LS Seq Number: 80000004
Checksum: 0x8436
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 69.1.1.1
External Route Tag: 0
to make FA 0.0.0.0 we will suppress this on ABR ( R5)
R5
router ospf 10
area 0 filter-list prefix test in
area 3 nssa translate type7 suppress-fa
to know about filter list click
now
R5#sh ip ospf database external 66.6.6.6
OSPF Router with ID (55.5.5.5) (Process ID 10)
Type-5 AS External Link States
LS age: 107
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 66.6.6.6 (External Network Number )
Advertising Router: 55.5.5.5
LS Seq Number: 80000005
Checksum: 0x61A0
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 0.0.0.0
External Route Tag: 0
R2#sh ip route 66.6.6.6
Routing entry for 66.6.6.6/32
Known via "ospf 10", distance 110, metric 20, type extern 2, forward metric 1
Last update from 25.0.0.5 on FastEthernet0/0, 00:02:21 ago
Routing Descriptor Blocks:
* 25.0.0.5, from 55.5.5.5, 00:02:21 ago, via FastEthernet0/0
Route metric is 20, traffic share count is 1
OSPF Router with ID (2.2.2.2) (Process ID 10)
Type-5 AS External Link States
Routing Bit Set on this LSA in topology Base with MTID 0
LS age: 180
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 66.6.6.6 (External Network Number )
Advertising Router: 55.5.5.5
LS Seq Number: 80000005
Checksum: 0x61A0
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 0.0.0.0 // Now this will follow next-hop recursion//
External Route Tag: 0
No comments:
Post a Comment