OSPF over DMVPN
R2 - HUB
R4 & R9 Spoke
R2
Public Interface :- GigabitEthernet1/0 :- IP 28.0.0.2 2
interface Tunnel0
ip address 172.16.0.2 255.255.255.0
no ip redirects
ip nhrp authentication DMVPN
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip ospf network point-to-multipoint
tunnel source GigabitEthernet1/0
tunnel mode gre multipoint
R9
Public Interface :-FastEthernet1/1 IP:- 98.0.0.9
interface Tunnel0
ip address 172.16.0.9 255.255.255.0
no ip redirects
ip nhrp authentication DMVPN
ip nhrp map 172.16.0.2 28.0.0.2
ip nhrp map multicast 28.0.0.2
ip nhrp network-id 1
ip nhrp nhs 172.16.0.2
tunnel source FastEthernet1/1
tunnel mode gre multipoint
R4
Public Interface :-FastEthernet0/0 IP :-84.0.0.4
interface Tunnel0
ip address 172.16.0.4 255.255.255.0
no ip redirects
ip nhrp authentication DMVPN
ip nhrp map 172.16.0.2 28.0.0.2
ip nhrp map multicast 28.0.0.2
ip nhrp network-id 1
ip nhrp nhs 172.16.0.2
tunnel source FastEthernet0/0
tunnel mode gre multipoint
R2
R2#sh dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================
Interface: Tunnel0, IPv4 NHRP Details
Type:Hub, NHRP Peers:2,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 84.0.0.4 172.16.0.4 UP 01:40:54 D
1 98.0.0.9 172.16.0.9 UP 01:42:43 D
R9
R9#sh dmvpn
==========================================================================
Interface: Tunnel0, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 28.0.0.2 172.16.0.2 UP 01:44:14 S
R4
sh dmvpn
Interface: Tunnel0, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 28.0.0.2 172.16.0.2 UP 01:42:43 S
***************************************************************
***********************OSPF*********************
OSPF Configuration
R9
router ospf 10
network 9.9.9.9 0.0.0.0 area 2
network 172.16.0.9 0.0.0.0 area 2
R2
router ospf 10
network 23.0.0.0 0.0.0.255 area 0
network 25.0.0.0 0.0.0.255 area 0
network 172.16.0.2 0.0.0.0 area 2
R4
router ospf 10
network 34.0.0.0 0.0.0.255 area 0
network 172.16.0.4 0.0.0.0 area 2
Neigborship will be flap
R2
*Aug 19 02:50:51.419: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.0.9 on Tunnel0 from LOADING to DOWN, Neighbor Down: Adjacency forced to reset
*Aug 19 02:50:52.059: %OSPF-5-ADJCHG: Process 10, Nbr 44.4.4.4 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
*Aug 19 02:50:52.163: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.0.9 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
R2#
*Aug 19 02:50:52.691: %OSPF-5-ADJCHG: Process 10, Nbr 44.4.4.4 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
*Aug 19 02:50:53.263: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.0.9 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
R2#
*Aug 19 02:50:53.963: %OSPF-5-ADJCHG: Process 10, Nbr 44.4.4.4 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
*Aug 19 02:50:54.123: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.0.9 on Tunnel0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
sh ip ospf int tun0
R2#sh ip ospf int tun 0
Tunnel0 is up, line protocol is up
Internet Address 172.16.0.2/24, Area 2, Attached via Network Statement
Process ID 10, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 1000
Topology-MTID Cost Disabled Shutdown Topology Name
0 1000 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
in point to point network only one neighbor is allowed but here it making more then one network.
to avoid this
we will have to change network type.
R2-R4-R9
1- Point-to-multipoint
int tun0
ip ospf network point-to-multipoint
Now in R2
R2#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
39.1.4.1 1 FULL/DR 00:00:38 23.0.0.3 FastEthernet0/1
55.5.5.5 1 FULL/BDR 00:00:37 25.0.0.5 FastEthernet0/0
44.4.4.4 0 FULL/ - 00:01:56 172.16.0.4 Tunnel0
172.16.0.9 0 FULL/ - 00:01:43 172.16.0.9 Tunnel0
R9#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:01:40 172.16.0.2 Tunnel0
R4#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
39.1.4.1 1 FULL/BDR 00:00:37 34.0.0.3 GigabitEthernet1/0
2.2.2.2 0 FULL/ - 00:01:38 172.16.0.2 Tunnel0
2- Broadcast
R2- DR
int tun0
ip ospf network broadcast
R4- R9
int tun0
ip ospf network broadcast
ip ospf priority 0
R4#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
39.1.4.1 1 FULL/BDR 00:00:32 34.0.0.3 GigabitEthernet1/0
2.2.2.2 1 FULL/DR 00:00:31 172.16.0.2 Tunnel0
R9
R9#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1 FULL/DR 00:00:30 172.16.0.2 Tunnel0
R2#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
44.4.4.4 0 FULL/DROTHER 00:00:33 172.16.0.4 Tunnel0
172.16.0.9 0 FULL/DROTHER 00:00:33 172.16.0.9 Tunnel0
R2#sh ip ospf int tun0
Tunnel0 is up, line protocol is up
Internet Address 172.16.0.2/24, Area 2, Attached via Network Statement
Process ID 10, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1000
Topology-MTID Cost Disabled Shutdown Topology Name
0 1000 no no Base
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 172.16.0.2
No backup designated router on this network
R9#sh ip ospf int tun0
Tunnel0 is up, line protocol is up
Internet Address 172.16.0.9/24, Area 2, Attached via Network Statement
Process ID 10, Router ID 172.16.0.9, Network Type BROADCAST, Cost: 1000
Topology-MTID Cost Disabled Shutdown Topology Name
0 1000 no no Base
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 2.2.2.2, Interface address 172.16.0.2
No backup designated router on this network
R4
R4#sh ip ospf int tun0
Tunnel0 is up, line protocol is up
Internet Address 172.16.0.4/24, Area 2, Attached via Network Statement
Process ID 10, Router ID 44.4.4.4, Network Type BROADCAST, Cost: 1000
Topology-MTID Cost Disabled Shutdown Topology Name
0 1000 no no Base
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 2.2.2.2, Interface address 172.16.0.2
3:- Non Broadcast
R2
interface Tunnel0
ip ospf network non-broadcast
R4-R9
int tun0
ip ospf network non-broadcast
ip ospf priority 0
R2
44.4.4.4 0 FULL/DROTHER 00:01:47 172.16.0.4 Tunnel0
172.16.0.9 0 FULL/DROTHER 00:01:58 172.16.0.9 Tunnel0
R2#
R9#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1 FULL/DR 00:01:31 172.16.0.2 Tunnel0
R9#
R4#sh ip ospf nei
2.2.2.2 1 FULL/DR 00:01:05 172.16.0.2 Tunnel0
R4#
R9#sh ip route ospf
Gateway of last resort is not set
6.0.0.0/32 is subnetted, 1 subnets
O IA 6.6.6.6 [110/1003] via 172.16.0.2, 00:04:08, Tunnel0
13.0.0.0/24 is subnetted, 1 subnets
O IA 13.0.0.0 [110/1002] via 172.16.0.4, 00:04:03, Tunnel0
[110/1002] via 172.16.0.2, 00:04:08, Tunnel0
15.0.0.0/24 is subnetted, 1 subnets
O IA 15.0.0.0 [110/1002] via 172.16.0.2, 00:04:08, Tunnel0
16.0.0.0/24 is subnetted, 1 subnets
O IA 16.0.0.0 [110/1003] via 172.16.0.4, 00:04:03, Tunnel0
[110/1003] via 172.16.0.2, 00:04:08, Tunnel0
23.0.0.0/24 is subnetted, 1 subnets
O IA 23.0.0.0 [110/1001] via 172.16.0.2, 00:04:08, Tunnel0
25.0.0.0/24 is subnetted, 1 subnets
O IA 25.0.0.0 [110/1001] via 172.16.0.2, 00:04:08, Tunnel0
34.0.0.0/24 is subnetted, 1 subnets
O IA 34.0.0.0 [110/1001] via 172.16.0.4, 00:04:03, Tunnel0
56.0.0.0/24 is subnetted, 1 subnets
O IA 56.0.0.0 [110/1002] via 172.16.0.2, 00:04:08, Tunnel0
R9#
6.0.0.0/32 is subnetted, 1 subnets
O IA 6.6.6.6 [110/1003] via 172.16.0.2, 00:04:08, Tunnel0
13.0.0.0/24 is subnetted, 1 subnets
O IA 13.0.0.0 [110/1002] via 172.16.0.4, 00:04:03, Tunnel0
[110/1002] via 172.16.0.2, 00:04:08, Tunnel0
15.0.0.0/24 is subnetted, 1 subnets
O IA 15.0.0.0 [110/1002] via 172.16.0.2, 00:04:08, Tunnel0
16.0.0.0/24 is subnetted, 1 subnets
O IA 16.0.0.0 [110/1003] via 172.16.0.4, 00:04:03, Tunnel0
[110/1003] via 172.16.0.2, 00:04:08, Tunnel0
23.0.0.0/24 is subnetted, 1 subnets
O IA 23.0.0.0 [110/1001] via 172.16.0.2, 00:04:08, Tunnel0
25.0.0.0/24 is subnetted, 1 subnets
O IA 25.0.0.0 [110/1001] via 172.16.0.2, 00:04:08, Tunnel0
34.0.0.0/24 is subnetted, 1 subnets
O IA 34.0.0.0 [110/1001] via 172.16.0.4, 00:04:03, Tunnel0
56.0.0.0/24 is subnetted, 1 subnets
O IA 56.0.0.0 [110/1002] via 172.16.0.2, 00:04:08, Tunnel0
R9#
R4
Gateway of last resort is not set
6.0.0.0/32 is subnetted, 1 subnets
O IA 6.6.6.6 [110/4] via 34.0.0.3, 01:30:39, GigabitEthernet1/0
9.0.0.0/32 is subnetted, 1 subnets
O 9.9.9.9 [110/1001] via 172.16.0.9, 00:05:15, Tunnel0
13.0.0.0/24 is subnetted, 1 subnets
O 13.0.0.0 [110/2] via 34.0.0.3, 02:21:11, GigabitEthernet1/0
15.0.0.0/24 is subnetted, 1 subnets
O 15.0.0.0 [110/3] via 34.0.0.3, 01:34:53, GigabitEthernet1/0
16.0.0.0/24 is subnetted, 1 subnets
O IA 16.0.0.0 [110/3] via 34.0.0.3, 01:34:05, GigabitEthernet1/0
23.0.0.0/24 is subnetted, 1 subnets
O 23.0.0.0 [110/2] via 34.0.0.3, 02:21:11, GigabitEthernet1/0
25.0.0.0/24 is subnetted, 1 subnets
O 25.0.0.0 [110/3] via 34.0.0.3, 00:07:06, GigabitEthernet1/0
56.0.0.0/24 is subnetted, 1 subnets
O IA 56.0.0.0 [110/4] via 34.0.0.3, 01:32:31, GigabitEthernet1/0
R4#
Gateway of last resort is not set
6.0.0.0/32 is subnetted, 1 subnets
O IA 6.6.6.6 [110/4] via 34.0.0.3, 01:30:39, GigabitEthernet1/0
9.0.0.0/32 is subnetted, 1 subnets
O 9.9.9.9 [110/1001] via 172.16.0.9, 00:05:15, Tunnel0
13.0.0.0/24 is subnetted, 1 subnets
O 13.0.0.0 [110/2] via 34.0.0.3, 02:21:11, GigabitEthernet1/0
15.0.0.0/24 is subnetted, 1 subnets
O 15.0.0.0 [110/3] via 34.0.0.3, 01:34:53, GigabitEthernet1/0
16.0.0.0/24 is subnetted, 1 subnets
O IA 16.0.0.0 [110/3] via 34.0.0.3, 01:34:05, GigabitEthernet1/0
23.0.0.0/24 is subnetted, 1 subnets
O 23.0.0.0 [110/2] via 34.0.0.3, 02:21:11, GigabitEthernet1/0
25.0.0.0/24 is subnetted, 1 subnets
O 25.0.0.0 [110/3] via 34.0.0.3, 00:07:06, GigabitEthernet1/0
56.0.0.0/24 is subnetted, 1 subnets
O IA 56.0.0.0 [110/4] via 34.0.0.3, 01:32:31, GigabitEthernet1/0
R4#
R4#sh ip ospf data
OSPF Router with ID (44.4.4.4) (Process ID 10)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 1569 0x80000008 0x00AE26 2
2.2.2.2 2.2.2.2 491 0x80000008 0x005549 2
39.1.4.1 39.1.4.1 396 0x8000000D 0x004DBF 3
44.4.4.4 44.4.4.4 678 0x80000006 0x000769 1
55.5.5.5 55.5.5.5 498 0x80000009 0x00D05C 2
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
13.0.0.3 39.1.4.1 396 0x80000005 0x00BF08
15.0.0.1 1.1.1.1 1569 0x80000003 0x00F4E4
23.0.0.3 39.1.4.1 496 0x80000007 0x006B4C
25.0.0.5 55.5.5.5 501 0x80000001 0x003B4C
34.0.0.4 44.4.4.4 678 0x80000005 0x007002
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
6.6.6.6 1.1.1.1 1569 0x80000003 0x0066B6
6.6.6.6 55.5.5.5 1659 0x80000003 0x002AB0
9.9.9.9 2.2.2.2 371 0x80000001 0x00EB38
9.9.9.9 44.4.4.4 370 0x80000001 0x0046AD
16.0.0.0 1.1.1.1 1825 0x80000003 0x00A085
16.0.0.0 55.5.5.5 1659 0x80000003 0x006E74
56.0.0.0 1.1.1.1 1569 0x80000003 0x00A05C
56.0.0.0 55.5.5.5 1659 0x80000003 0x005A61
172.16.0.0 2.2.2.2 492 0x80000001 0x00FB90
172.16.0.0 44.4.4.4 1483 0x80000001 0x005606
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 380 0x80000002 0x006B4D 1
44.4.4.4 44.4.4.4 344 0x80000015 0x0055ED 1
172.16.0.9 172.16.0.9 363 0x80000014 0x00846B 2
Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
172.16.0.2 2.2.2.2 380 0x80000001 0x005A0F
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
6.6.6.6 2.2.2.2 490 0x80000001 0x0056C3
6.6.6.6 44.4.4.4 1704 0x80000004 0x00B431
13.0.0.0 2.2.2.2 490 0x80000001 0x00B76E
13.0.0.0 44.4.4.4 678 0x80000005 0x000AE7
15.0.0.0 2.2.2.2 490 0x80000001 0x009D86
15.0.0.0 44.4.4.4 1944 0x80000003 0x00FDF2
16.0.0.0 2.2.2.2 490 0x80000001 0x009A87
16.0.0.0 44.4.4.4 1704 0x80000003 0x00F0FE
23.0.0.0 2.2.2.2 490 0x80000001 0x002BF1
23.0.0.0 44.4.4.4 678 0x80000005 0x008760
25.0.0.0 2.2.2.2 490 0x80000001 0x00110A
25.0.0.0 44.4.4.4 480 0x80000007 0x00736F
34.0.0.0 2.2.2.2 490 0x80000001 0x00A56B
34.0.0.0 44.4.4.4 678 0x80000005 0x00EDEF
56.0.0.0 2.2.2.2 490 0x80000001 0x008674
56.0.0.0 44.4.4.4 1704 0x80000003 0x00F0D5
R4#
Point-to-multipoint non-broadcast
int tun0
ip ospf network point-to-multipoint non-broadcast
router ospf 10
network 23.0.0.0 0.0.0.255 area 0
network 25.0.0.0 0.0.0.255 area 0
network 172.16.0.2 0.0.0.0 area 2
neighbor 172.16.0.4
neighbor 172.16.0.9
R4-R9
nt tun0
ip ospf network point-to-multipoint non-broadcast
Tunnel0 is up, line protocol is up
Internet Address 172.16.0.2/24, Area 2, Attached via Network Statement
Process ID 10, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 1000
Topology-MTID Cost Disabled Shutdown Topology Name
0 1000 no no Base
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:06
int tun0
ip ospf network point-to-multipoint non-broadcast
router ospf 10
network 23.0.0.0 0.0.0.255 area 0
network 25.0.0.0 0.0.0.255 area 0
network 172.16.0.2 0.0.0.0 area 2
neighbor 172.16.0.4
neighbor 172.16.0.9
R4-R9
nt tun0
ip ospf network point-to-multipoint non-broadcast
R2
Internet Address 172.16.0.2/24, Area 2, Attached via Network Statement
Process ID 10, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 1000
Topology-MTID Cost Disabled Shutdown Topology Name
0 1000 no no Base
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:06
No DR-BDR selection in this network type
R4
R4# sh ip route 9.9.9.9
Routing entry for 9.9.9.9/32
Known via "ospf 10", distance 110, metric 2001, type intra area
Last update from 172.16.0.2 on Tunnel0, 00:02:25 ago
Routing Descriptor Blocks:
* 172.16.0.2, from 172.16.0.9, 00:02:25 ago, via Tunnel0
Route metric is 2001, traffic share count is 1
R4#
R4#trace 9.9.9.9
Type escape sequence to abort.
Tracing the route to 9.9.9.9
VRF info: (vrf in name/id, vrf out name/id)
1 172.16.0.2 364 msec 192 msec 168 msec
2 172.16.0.9 248 msec 324 msec 232 msec
R4#
R4# sh ip route 9.9.9.9
Routing entry for 9.9.9.9/32
Known via "ospf 10", distance 110, metric 2001, type intra area
Last update from 172.16.0.2 on Tunnel0, 00:02:25 ago
Routing Descriptor Blocks:
* 172.16.0.2, from 172.16.0.9, 00:02:25 ago, via Tunnel0
Route metric is 2001, traffic share count is 1
R4#
R4#trace 9.9.9.9
Type escape sequence to abort.
Tracing the route to 9.9.9.9
VRF info: (vrf in name/id, vrf out name/id)
1 172.16.0.2 364 msec 192 msec 168 msec
2 172.16.0.9 248 msec 324 msec 232 msec
R4#
R2
R2#sh ip ospf database router self-originate
e
Router Link States (Area 2)
LS age: 723
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 2.2.2.2
Advertising Router: 2.2.2.2
LS Seq Number: 8000000E
Checksum: 0x499D
Length: 60
Area Border Router
Number of Links: 3
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 44.4.4.4
(Link Data) Router Interface address: 172.16.0.2
Number of MTID metrics: 0
TOS 0 Metrics: 1000
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 172.16.0.9
(Link Data) Router Interface address: 172.16.0.2
Number of MTID metrics: 0
TOS 0 Metrics: 1000
Link connected to: a Stub Network
(Link ID) Network/subnet number: 172.16.0.2
(Link Data) Network Mask: 255.255.255.255
Number of MTID metrics: 0
TOS 0 Metrics: 0
No comments:
Post a Comment